diff --git a/updater/l10n-supported/Makefile b/updater/l10n-supported/Makefile
index ceb123a6727479221817c4564999d57610cbe67e..9e0120485e92053e9ed83d9a936ce45134bfdeb3 100644
--- a/updater/l10n-supported/Makefile
+++ b/updater/l10n-supported/Makefile
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=l10n-supported
-PKG_VERSION:=1.3
-PKG_RELEASE:=5
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
 
diff --git a/updater/l10n-supported/files/uci-defaults b/updater/l10n-supported/files/uci-defaults
index fae3850c1372dd51fdb9a0f015b0254567078874..7b10a4dec00ba0232062b1be63d0e8de8dd78b7c 100644
--- a/updater/l10n-supported/files/uci-defaults
+++ b/updater/l10n-supported/files/uci-defaults
@@ -16,13 +16,13 @@ if ! uci -q get updater.l10n; then
 fi
 
 if [ -f "$bootstrap" ]; then
-	while IFS="," read -r lang; do
+	tr ',' '\n' < "$bootstrap" | while read -r lang; do
 		[ "$lang" != "en" ] || continue
 		uci -q batch <<-EOF
 			del_list updater.l10n.langs='$lang'
 			add_list updater.l10n.langs='$lang'
 		EOF
-	done < "$bootstrap"
+	done
 	rm -f "$bootstrap"
 fi
 
diff --git a/updater/pkglists/Makefile b/updater/pkglists/Makefile
index 26899b9872a1c0e1483adf6c3b8d2525e2197f20..555c3636c3733e317d7a57519d8277ec762488b3 100644
--- a/updater/pkglists/Makefile
+++ b/updater/pkglists/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkglists
-PKG_VERSION:=1.6.0
+PKG_VERSION:=1.6.1
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
diff --git a/updater/pkglists/files/uci-defaults b/updater/pkglists/files/uci-defaults
index 2179ac8d6f669e297ecdb48473e877bbd4649ca2..2d269349be52bdaca5a0811800c03f990f63880b 100644
--- a/updater/pkglists/files/uci-defaults
+++ b/updater/pkglists/files/uci-defaults
@@ -10,7 +10,7 @@ set -eu
 bootstrap="/usr/share/updater/bootstrap-pkgfiles"
 
 if [ -f "$bootstrap" ]; then
-	while IFS="," read -r pkglist; do
+	tr ',' '\n' < "$bootstrap" | while read -r pkglist; do
 		name="${pkglist%%(*}"
 		options="${pkglist#*(}"; options="${options%)}"
 		uci -q batch <<-EOF
@@ -20,11 +20,11 @@ if [ -f "$bootstrap" ]; then
 		EOF
 		if [ -n "$options" ]; then
 			uci set "pkglists.$name=$name"
-			echo "$options" | while IFS="|" read -r option; do
+			echo "$options" | tr '|' '\n' | while read -r option; do
 				uci set "pkglists.$name.$option=1"
 			done
 			uci commit "pkglists.$name"
 		fi
-	done < "$bootstrap"
+	done
 	rm -f "$bootstrap"
 fi