Use an older version of werkzeug to fix python tests in CI

It seems that there is an issue with werkzeug > 2.0.3

The Python tests are failing on the newer versions:
!316 (comment 249166)
3 jobs for CI-fix in 2 minutes and 33 seconds (queued for 7 seconds)