Skip to content
Snippets Groups Projects
Verified Commit 006a027e authored by Josef Schlehofer's avatar Josef Schlehofer
Browse files

python-bottle-i18n: drop unused package

This package was a dependency for Foris, but Foris was removed in
develop branch already for Turris OS 6.0, this is a leftover, so drop
this.
parent a5e99d48
Branches
Tags
1 merge request!982Turris OS 6.0 (HBK) (turrispackages)
#
# Copyright (C) 2013-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-bottle-i18n
PKG_VERSION:=0.1.5
PKG_RELEASE:=$(AUTORELEASE)
PYPI_NAME:=bottle-i18n
PKG_HASH:=7f9d343ae30b18a9676cbe612a8be2e99d4741aa4aa6a1b875ea232ba94c7678
PKG_BUILD_DIR:=$(BUILD_DIR)/bottle-i18n-$(PKG_VERSION)
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/python3-bottle-i18n
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=python3-bottle-i18n
URL:=https://github.com/iocast/bottle-i18n
DEPENDS:=+python3-light +python3-bottle
endef
define Package/python3-bottle-i18n/description
i18n support for bottle.py
endef
PYTHON3_PKG_SETUP_ARGS:=
$(eval $(call Py3Package,python3-bottle-i18n))
$(eval $(call BuildPackage,python3-bottle-i18n))
$(eval $(call BuildPackage,python3-bottle-i18n-src))
--- a/bottle_i18n.py
+++ b/bottle_i18n.py
@@ -179,7 +179,7 @@ class I18NPlugin(object):
for app in self._apps:
app._ = trans.gettext
self._cache[self._lang_code] = trans
- except Exception, e:
+ except Exception as e:
for app in self._apps:
app._ = lambda s: s
self._cache[self._lang_code] = None
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment