Skip to content
Snippets Groups Projects
Verified Commit 201e6a26 authored by Karel Koci's avatar Karel Koci :metal:
Browse files

libnfsidmap: drop package

This package seems to not be used anywhere. nfs-utils were dropped and
are now maintained by uptream so this should not be in our repository.
parent 933a3959
Branches
Tags
No related merge requests found
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=libnfsidmap
PKG_VERSION:=0.25
PKG_RELEASE:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/
PKG_MD5SUM:=2ac4893c92716add1a1447ae01df77ab
include $(INCLUDE_DIR)/package.mk
define Package/libnfsidmap
SECTION:=libs
CATEGORY:=Libraries
TITLE:=libnfsidmap, for compiling mount.nfs4
URL:=http://www.citi.umich.edu/projects/nfsv4
endef
define Package/libnfsidmap/description
Library needed by nfs-utils
endef
TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
MAKE_FLAGS += \
OPT="$(TARGET_CFLAGS)" \
INSTALLSUID="install -m 4755" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all
define Build/InstallDev
$(MAKE) -C "$(PKG_BUILD_DIR)" INSTALLSUID="install -m 4755" DESTDIR="$(1)" install
find "$(1)" -name '*.a' -delete
endef
define Package/libnfsidmap/install
$(MAKE) -C "$(PKG_BUILD_DIR)" INSTALLSUID="install -m 4755" DESTDIR="$(1)" install
find "$(1)" -name '*.a' -delete
rm -rf "$(1)"/usr/include
rm -rf "$(1)"/usr/man
rm -rf "$(1)"/usr/lib/pkgconfig
endef
$(eval $(call BuildPackage,libnfsidmap))
--- ./cfg.h.bak 2017-08-28 14:56:28.813736854 +0200
+++ ./cfg.h 2017-08-28 14:56:43.118215951 +0200
@@ -34,6 +34,7 @@
#define _CONF_H_
#include "queue.h"
+#include <sys/types.h>
struct conf_list_node {
TAILQ_ENTRY(conf_list_node) link;
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment