Skip to content
Snippets Groups Projects
Verified Commit b86d4093 authored by Josef Schlehofer's avatar Josef Schlehofer
Browse files

reforis: update to version 1.1.2

Add external link to UserOptions
Improve intro description of Packages
Provide info whether user is logged in to JS
Add & update translations
Add light/dark favicon switch
backend.py: new linter version requires encoding
Fix python linting f-string errors
Rename Data Collection card to Threat Detection
Don't set socket when starting WSGIServer
Respond with 401 and rename the file
NPM audit fix

(cherry picked from commit 76693330)
parent d5d5ef63
Branches
Tags
1 merge request!842reforis: update to version 1.1.2
......@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=reforis
PKG_VERSION:=1.1.1
PKG_RELEASE:=4
PKG_VERSION:=1.1.2
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/reforis/reforis
PKG_MIRROR_HASH:=1482fe19b9c945a661696aced221053f592ff82a872640a396ed5ec5344f05a2
PKG_MIRROR_HASH:=03d835b3863051777b5a6e5437b87ff9bb51d14b4b18402af7d062b5a70b0a26
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
......
From b039e946ad36c44bb8153a12f3fe60e503d8dedc Mon Sep 17 00:00:00 2001
From: Stepan Henek <stepan.henek@nic.cz>
Date: Wed, 1 Sep 2021 10:07:40 +0200
Subject: [PATCH] Don't set socket when starting WSGIServer
Note that if reforis is started using lighttpd, lighttpd
is responsible for creating the socket not reforis.
Kudos to Glenn Strauss
see https://flask.palletsprojects.com/en/2.0.x/deploying/fastcgi/#configuring-lighttpd
---
reforis/__main__.py | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/reforis/__main__.py b/reforis/__main__.py
index 2f641055..96767317 100644
--- a/reforis/__main__.py
+++ b/reforis/__main__.py
@@ -1,6 +1,6 @@
#
# reforis
-# Copyright (C) 2019 CZ.NIC, z.s.p.o. (http://www.nic.cz/)
+# Copyright (C) 2021 CZ.NIC, z.s.p.o. (http://www.nic.cz/)
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -17,8 +17,6 @@
# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
#
-import os
-
from flup.server.fcgi import WSGIServer
from . import create_app
@@ -39,7 +37,6 @@ def main():
WSGIServer(
app,
debug=True,
- bindAddress=os.environ.get('FCGI_SOCKET', '/tmp/fastcgi.reforis.socket-0')
).run()
--
2.33.0
From b59491861e8c38a3a2795b96a868d675d76b75f1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marek=20Sa=C5=A1ek?= <marek.sasek@nic.cz>
Date: Tue, 7 Sep 2021 16:37:38 +0200
Subject: [PATCH] Rename Data Collection card
---
js/src/overview/Cards/DataCollectionCard.js | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/js/src/overview/Cards/DataCollectionCard.js b/js/src/overview/Cards/DataCollectionCard.js
index 96044f27..31999bf2 100644
--- a/js/src/overview/Cards/DataCollectionCard.js
+++ b/js/src/overview/Cards/DataCollectionCard.js
@@ -1,5 +1,5 @@
/*
- * Copyright (C) 2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+ * Copyright (C) 2020-2021 CZ.NIC z.s.p.o. (http://www.nic.cz/)
*
* This is free software, licensed under the GNU General Public License v3.
* See /LICENSE for more information.
@@ -41,7 +41,7 @@ function DataCollectionCard({ details: { eula } }) {
<div className="row align-items-center">
<div className="col">
<h6 className="text-uppercase text-muted mb-2">
- {_("Data Collection")}
+ {_("Threat Detection")}
</h6>
<span className="status">
{eula === 1 ? _("Activated") : _("Disabled")}
--
2.30.2
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment